LibGPG-Error

From CBLFS
Jump to: navigation, search
Download Source: ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-1.10.tar.bz2

Contents

Introduction to LibGPG-Error

Libgpg-error is a small library that defines common error values for all GnuPG components. Among these are GPG, GPGSM, GPGME, GPG-Agent, libgcrypt, Libksba, DirMngr, Pinentry, SmartCard Daemon and possibly more in the future.

Project Homepage: http://www.gnupg.org/related_software/libgpg-error/


Dependencies

Non-Multilib

Compile the package:

./configure --prefix=/usr &&
make

Install the package

make install

Multilib

32Bit

Compile the package:

CC="gcc ${BUILD32}" ./configure --prefix=/usr &&
make

Install the package

make install &&
mv -v /usr/bin/gpg-error-config{,-32}

N32

Compile the package:

CC="gcc ${BUILDN32}" ./configure --prefix=/usr --libdir=/usr/lib32 &&
make

Install the package

make install &&
mv -v /usr/bin/gpg-error-config{,-n32}

64Bit

Compile the package:

CC="gcc ${BUILD64}" ./configure --prefix=/usr --libdir=/usr/lib64 &&
make

Install the package

make install &&
mv -v /usr/bin/gpg-error-config{,-64} &&
ln -sfv multiarch_wrapper /usr/bin/gpg-error-config

Contents

Installed Programs: gpg-error, gpg-error-config
Installed Libraries: libgpg-error.{a,la,so}
Installed Directories: /usr/share/common-lisp/source/gpg-error

Short Descriptions

program1  ???
program2  ???
Personal tools